Aug 6, 2012

Sudden hue shift to blue in Mountain Lion

Today I noticed that running Google Chrome in Mountain Lion causes hue shift to blue on my MacBook Pro LCD display. I work with photos a lot and have a calibrated display. Sudden hue shift is very noticeable when you are used to work with calibrated, neutral gray monitors.

It seems that issue is specific to Mountain Lion only and it is caused when the system switches between integrated Intel and more powerful ATI or Nvidia graphics cards. There are two threads about this: here and here. At the end of the first link there is a post that reseting PRAM fixes the issue. I tried that but I cannot yet confirm if it fixes the issue or not. One thing I noticed is that after reseting PRAM my MBP does not switch to the advanced graphics when I run Twitter or Chrome. Before resting any of this apps were causing such switching.

In case if you have hue shift issue, I would appreciate if you write that in comments. There is no need to write if you do NOT have the issue :)

Thank you!

Update: more links about the issue:
Apple communitiy #1
Apple community #2
Apple community #3
Apple community #4
MacRumors thread

So it is a Mountain Lion bug.

[Update, Aug 14, 2012] The issue is fixed in OS X 10.8.1 (developer preview build 12B13).

[Update, Sept 02, 2012] The issue is back in OS X 10.8.2 (developer preview build 12C31a).

[Update, Nov 27, 2012] It appears that the problem is specific to MacBook Pros with SSD. Looks like they load too fast. OS X runs multiple tasks in parallel and it tries to load the correct color profile into the discrete card too early. To solve the issue, log out from the current user and log in. Hue will disappear.

5 comments:

  1. Hey I just updated mountain lion for OS X 10.8.2 and I'm having this issue for the first time. I don't know what happened but I use chrome and everytime I open facebook everything turns into blue. Do you know why this happens? because when I close the browser everything seem to be alright. What is this issue about? Is there anyway of fixing the problem? because I also work with photos and as far as i know I just have to close the facebook tab on chorme and everything is fine, but still sort of annoying.
    Thank you. :)

    ReplyDelete
  2. No solution yet but the problem most likely happens only on Mountain Lion with MacBooks that have SSD.

    http://forums.macrumors.com/showthread.php?t=1401741

    ReplyDelete
  3. "It appears that the problem is specific to MacBook Pros with SSD." ... unfortunately, nope. I have the same problem on my Mid-2012 15-inch MBP with SATA hard drive running 10.8.2. :(

    Helena, the work-around posted by Umputun and John in Paris at the link below is working for me until it gets fixed:
    https://discussions.apple.com/message/19215339#19215339

    ReplyDelete
    Replies
    1. Log out and log in fixes the issue too. No need to reboot or manipulate the setting.

      Delete
  4. I have the same issue. Mac OS X 10.8.2 with SSD.
    Logging out then back in does indeed solve the issue.

    ReplyDelete